A Windows 98 & ME forum. Win98banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Win98banter forum » Windows 98 » Networking
Site Map Home Authors List Search Today's Posts Mark Forums Read Web Partners

internet connection sharing



 
 
Thread Tools Display Modes
  #1  
Old July 24th 04, 10:48 PM
george
external usenet poster
 
Posts: n/a
Default internet connection sharing

Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs - windows
setup - internet tools - details -
When I place a check-mark at internet connection sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb network
device (one computer has a nic the other the usb device,
it only finds the internal modem card. BTW both computers
can access the net successfully.

How can I tell the wizard to use the network device (or do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network device?

If I exit the wizard and restart the computer the check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer sharing
but that does not enable the 'network neighborhood' either.
  #2  
Old July 25th 04, 05:35 AM
Steve Winograd [MVP]
external usenet poster
 
Posts: n/a
Default internet connection sharing

In article , "george"
wrote:
Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs - windows
setup - internet tools - details -
When I place a check-mark at internet connection sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb network
device (one computer has a nic the other the usb device,
it only finds the internal modem card. BTW both computers
can access the net successfully.

How can I tell the wizard to use the network device (or do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network device?

If I exit the wizard and restart the computer the check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer sharing
but that does not enable the 'network neighborhood' either.


Enabling Internet Connection Sharing is only necessary when the
Internet (DSL modem, cable modem, etc) connects directly to a
computer. That doesn't apply to your setup, because the Internet
connects to the router's WAN (Internet) port, not to a computer. The
router will share the DSL connection with both computers.

If you've installed ICS, un-install it. Configure both computers'
network connections to obtain an IP address automatically, and the
router's built-in DHCP server will take care of all the settings.

To enable Network Neighborhood, try these steps, in order. If one
doesn't fix the problem, go on to the next one:

1. Go to Control Panel. If Tweak UI is present, double click it. On
the Desktop tab, put a check mark in the Network Neighborhood box,
click Apply and OK.

2. Go to Control Panel | Network. Remove Client for Microsoft
Networks if it's present. Then add Client for Microsoft Networks.
Reboot.

3. There could be a system policy hiding Network Neighborhood. Run
the registry editor, open this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer

Delete the value named "NoNetHood". Reboot.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
  #3  
Old July 29th 04, 05:39 PM
george
external usenet poster
 
Posts: n/a
Default internet connection sharing

See inline comments:
-----Original Message-----
In article 358e01c471c7$e5cbb620

, "george"
wrote:
Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs - windows
setup - internet tools - details -
When I place a check-mark at internet connection

sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb

network
device (one computer has a nic the other the usb device,
it only finds the internal modem card. BTW both

computers
can access the net successfully.

How can I tell the wizard to use the network device (or

do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network device?

If I exit the wizard and restart the computer the check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer

sharing
but that does not enable the 'network neighborhood'

either.

Enabling Internet Connection Sharing is only necessary

when the
Internet (DSL modem, cable modem, etc) connects directly

to a
computer. That doesn't apply to your setup, because the

Internet
connects to the router's WAN (Internet) port, not to a

computer. The
router will share the DSL connection with both computers.


**
Not talking about computers 'sharing' the modem - I want
to share files and printers between computers.
**

If you've installed ICS, un-install it. Configure both

computers'
network connections to obtain an IP address

automatically, and the
router's built-in DHCP server will take care of all the

settings.


**
What is ICS? Computers are set to automatically get IPs.
**

To enable Network Neighborhood, try these steps, in

order. If one
doesn't fix the problem, go on to the next one:

1. Go to Control Panel. If Tweak UI is present, double

click it. On
the Desktop tab, put a check mark in the Network

Neighborhood box,
click Apply and OK.


**
Network Neighborhood WAS already checked.
**


2. Go to Control Panel | Network. Remove Client for

Microsoft
Networks if it's present. Then add Client for Microsoft

Networks.
Reboot.


**
Had already done that several times with same result - no
neighborhood.
**

3. There could be a system policy hiding Network

Neighborhood. Run
the registry editor, open this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersio

n\Policies\Explorer

Delete the value named "NoNetHood". Reboot.


**
It was there, I deleted it and rebooted - same result, no
NN.

What now??
**

--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news

group
for everyone to see. I'm sorry, but I don't answer

questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
.

  #4  
Old July 29th 04, 07:54 PM
Steve Winograd [MVP]
external usenet poster
 
Posts: n/a
Default internet connection sharing

In article , "george"
wrote:
Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs - windows
setup - internet tools - details -
When I place a check-mark at internet connection sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb network
device (one computer has a nic the other the usb device,
it only finds the internal modem card. BTW both computers
can access the net successfully.

How can I tell the wizard to use the network device (or do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network device?

If I exit the wizard and restart the computer the check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer sharing
but that does not enable the 'network neighborhood' either.



**
See inline comments:
**


Enabling Internet Connection Sharing is only necessary when the
Internet (DSL modem, cable modem, etc) connects directly to a
computer. That doesn't apply to your setup, because the Internet
connects to the router's WAN (Internet) port, not to a computer. The
router will share the DSL connection with both computers.


**
Not talking about computers 'sharing' the modem - I want
to share files and printers between computers.
**


If you've installed ICS, un-install it. Configure both computers'
network connections to obtain an IP address automatically, and the
router's built-in DHCP server will take care of all the settings.


**
What is ICS? Computers are set to automatically get IPs.
**


To enable Network Neighborhood, try these steps, in order. If one
doesn't fix the problem, go on to the next one:

1. Go to Control Panel. If Tweak UI is present, double click it. On
the Desktop tab, put a check mark in the Network Neighborhood box,
click Apply and OK.


**
Network Neighborhood WAS already checked.
**


2. Go to Control Panel | Network. Remove Client for Microsoft
Networks if it's present. Then add Client for Microsoft Networks.
Reboot.


**
Had already done that several times with same result - no
neighborhood.
**


3. There could be a system policy hiding Network Neighborhood. Run
the registry editor, open this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Cur rentVersion\Policies\Explorer

Delete the value named "NoNetHood". Reboot.


**
It was there, I deleted it and rebooted - same result, no NN.

What now??
**


ICS is Internet Connection Sharing, which you said that you installed.
ICS lets a computer share its Internet connection with other
computers. It has nothing to do with sharing files. Since you have a
router, you don't need ICS. Un-install it.

Now that you've deleted the registry key that hid Network
Neighborhood, try this, rebooting after each step:

1. Un-check Network Neighborhood in Tweak UI.
2. Check Network Neighborhood in Tweak UI.
3. Un-install Client for Microsoft Networks.
4. Install Client for Microsoft Networks.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
  #5  
Old July 30th 04, 07:25 PM
george
external usenet poster
 
Posts: n/a
Default internet connection sharing

Sorry, unclear on the concept - How do I un-install ICS?
Is that the one with the 'wizard' problem? (The one that
won't stay checked in the 'windows setup'???)

Will try the other (tweak UI, etc.) when I clear up the
ICS question.

-----Original Message-----
In article 68e201c4758a$93edd330

, "george"
wrote:
Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs -

windows
setup - internet tools - details -
When I place a check-mark at internet connection

sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb

network
device (one computer has a nic the other the usb

device,
it only finds the internal modem card. BTW both

computers
can access the net successfully.

How can I tell the wizard to use the network device

(or do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network

device?

If I exit the wizard and restart the computer the

check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer

sharing
but that does not enable the 'network neighborhood'

either.


**
See inline comments:
**


Enabling Internet Connection Sharing is only necessary

when the
Internet (DSL modem, cable modem, etc) connects

directly to a
computer. That doesn't apply to your setup, because

the Internet
connects to the router's WAN (Internet) port, not to a

computer. The
router will share the DSL connection with both

computers.

**
Not talking about computers 'sharing' the modem - I want
to share files and printers between computers.
**


If you've installed ICS, un-install it. Configure both

computers'
network connections to obtain an IP address

automatically, and the
router's built-in DHCP server will take care of all the

settings.

**
What is ICS? Computers are set to automatically get IPs.
**


To enable Network Neighborhood, try these steps, in

order. If one
doesn't fix the problem, go on to the next one:

1. Go to Control Panel. If Tweak UI is present, double

click it. On
the Desktop tab, put a check mark in the Network

Neighborhood box,
click Apply and OK.


**
Network Neighborhood WAS already checked.
**


2. Go to Control Panel | Network. Remove Client for

Microsoft
Networks if it's present. Then add Client for

Microsoft Networks.
Reboot.


**
Had already done that several times with same result -

no
neighborhood.
**


3. There could be a system policy hiding Network

Neighborhood. Run
the registry editor, open this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Cu rrentVers

ion\Policies\Explorer

Delete the value named "NoNetHood". Reboot.


**
It was there, I deleted it and rebooted - same result,

no NN.

What now??
**


ICS is Internet Connection Sharing, which you said that

you installed.
ICS lets a computer share its Internet connection with

other
computers. It has nothing to do with sharing files.

Since you have a
router, you don't need ICS. Un-install it.

Now that you've deleted the registry key that hid Network
Neighborhood, try this, rebooting after each step:

1. Un-check Network Neighborhood in Tweak UI.
2. Check Network Neighborhood in Tweak UI.
3. Un-install Client for Microsoft Networks.
4. Install Client for Microsoft Networks.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news

group
for everyone to see. I'm sorry, but I don't answer

questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
.

  #6  
Old July 30th 04, 08:54 PM
Steve Winograd [MVP]
external usenet poster
 
Posts: n/a
Default internet connection sharing

In article , "george"
wrote:
Sorry, unclear on the concept - How do I un-install ICS?
Is that the one with the 'wizard' problem? (The one that
won't stay checked in the 'windows setup'???)

Will try the other (tweak UI, etc.) when I clear up the
ICS question.


Here's how you installed ICS:

Going to control panel - add/remove programs - windows
setup - internet tools - details -
When I place a check-mark at internet connection sharing,


Do the same thing, only remove the check mark.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
  #7  
Old July 31st 04, 06:53 PM
george
external usenet poster
 
Posts: n/a
Default internet connection sharing


-----Original Message-----
In article 68e201c4758a$93edd330

, "george"
wrote:
Two computers connected to a router and dsl service.
Tried the steps below for both computers.
I cannot enable sharing on either computer.
Going to control panel - add/remove programs -

windows
setup - internet tools - details -
When I place a check-mark at internet connection

sharing,
click ok, ok and the programs are loaded, then the
internet connecting sharing wizard opens.

Problem - the wizard cannot find the nic or a usb

network
device (one computer has a nic the other the usb

device,
it only finds the internal modem card. BTW both

computers
can access the net successfully.

How can I tell the wizard to use the network device

(or do
I let it use the modem and change the 'connection'
somewhere else?) And exactly HOW do I change the
connection setting from the modem to the network

device?

If I exit the wizard and restart the computer the

check-
mark on the "internet connection sharing" has been
removed, and there is no 'network neighborhood'.

How do I enable the network neighborhood?

I tried sharing using the control panel - network -
client for microsoft networks - file and printer

sharing
but that does not enable the 'network neighborhood'

either.


**
See inline comments:
**


Enabling Internet Connection Sharing is only necessary

when the
Internet (DSL modem, cable modem, etc) connects

directly to a
computer. That doesn't apply to your setup, because

the Internet
connects to the router's WAN (Internet) port, not to a

computer. The
router will share the DSL connection with both

computers.

**
Not talking about computers 'sharing' the modem - I want
to share files and printers between computers.
**


If you've installed ICS, un-install it. Configure both

computers'
network connections to obtain an IP address

automatically, and the
router's built-in DHCP server will take care of all the

settings.

**
What is ICS? Computers are set to automatically get IPs.
**


To enable Network Neighborhood, try these steps, in

order. If one
doesn't fix the problem, go on to the next one:

1. Go to Control Panel. If Tweak UI is present, double

click it. On
the Desktop tab, put a check mark in the Network

Neighborhood box,
click Apply and OK.


**
Network Neighborhood WAS already checked.
**


2. Go to Control Panel | Network. Remove Client for

Microsoft
Networks if it's present. Then add Client for

Microsoft Networks.
Reboot.


**
Had already done that several times with same result -

no
neighborhood.
**


3. There could be a system policy hiding Network

Neighborhood. Run
the registry editor, open this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Cu rrentVers

ion\Policies\Explorer

Delete the value named "NoNetHood". Reboot.


**
It was there, I deleted it and rebooted - same result,

no NN.

What now??
**


ICS is Internet Connection Sharing, which you said that

you installed.
ICS lets a computer share its Internet connection with

other
computers. It has nothing to do with sharing files.

Since you have a
router, you don't need ICS. Un-install it.

Now that you've deleted the registry key that hid Network
Neighborhood, try this, rebooting after each step:

1. Un-check Network Neighborhood in Tweak UI.
2. Check Network Neighborhood in Tweak UI.
3. Un-install Client for Microsoft Networks.
4. Install Client for Microsoft Networks.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news

group
for everyone to see. I'm sorry, but I don't answer

questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
.

Thanks for the clarification in the two posts below this
one.

First, I checked the registry and found that
the "NoNetHood" had come back. Deleted it again and
rebooted. Gone.

Then I went to the Network Neighborhood in Tweak UI and
unchecked that. When I exited Tweak UI a dialog box
appeared saying that I had to "Log Off" in order for the
change to take affect. I do not have a "Log Off" 'box' in
my start menu (I am the only user so there is no need ti
logoff for another user.)

After I rebooted, I checked both of the above and found
that the checkmark was back in NN and the NNH was back in
the registry.

What now?
  #8  
Old July 31st 04, 08:03 PM
Steve Winograd [MVP]
external usenet poster
 
Posts: n/a
Default internet connection sharing

In article , "george"
wrote:
Thanks for the clarification in the two posts below this
one.

First, I checked the registry and found that
the "NoNetHood" had come back. Deleted it again and
rebooted. Gone.

Then I went to the Network Neighborhood in Tweak UI and
unchecked that. When I exited Tweak UI a dialog box
appeared saying that I had to "Log Off" in order for the
change to take affect. I do not have a "Log Off" 'box' in
my start menu (I am the only user so there is no need ti
logoff for another user.)

After I rebooted, I checked both of the above and found
that the checkmark was back in NN and the NNH was back in
the registry.

What now?


Look for something that's adding the NoNetHood key to the registry in
these places:

Startup folder.
C:\Autoexec.bat
C:\Config.sys

Go to Start | Run | Msconfig, click the Startup tab, and see what's
running there.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
  #9  
Old August 3rd 04, 04:19 AM
george
external usenet poster
 
Posts: n/a
Default internet connection sharing


-----Original Message-----
In article 7c7701c47727$426a7740

, "george"
wrote:
Thanks for the clarification in the two posts below this
one.

First, I checked the registry and found that
the "NoNetHood" had come back. Deleted it again and
rebooted. Gone.

Then I went to the Network Neighborhood in Tweak UI and
unchecked that. When I exited Tweak UI a dialog box
appeared saying that I had to "Log Off" in order for the
change to take affect. I do not have a "Log Off" 'box'

in
my start menu (I am the only user so there is no need ti
logoff for another user.)

After I rebooted, I checked both of the above and found
that the checkmark was back in NN and the NNH was back

in
the registry.

What now?


Look for something that's adding the NoNetHood key to the

registry in
these places:

Startup folder.
C:\Autoexec.bat


** here is Autoexec.bat - I see nothing
REM [Header]
@ECHO On
REM [CD-ROM Drive]
REM [Miscellaneous]
rem TShoot: c:\windows\COMMAND\MODE LPT1:,,B
REM [Display]
@SET CLASSPATH=C:\PROGRA~1\PHOTOD~1.1\ADOBEC~1
keyb br,,c:\windows\COMMAND\keyboard.sys
**

C:\Config.sys


** here is config.sys I don't see anything here either
DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMEM:OFF /M:1
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS
REM [Header]
dos=high,umb
files=150
buffers=60,0
stacks=12,256
REM == PISETUP Begin Delete ==
REM == PISETUP End Delete ==
REM [CD-ROM Drive]
REM [Miscellaneous]
REM [Display]
**

***
Where do I look next?
***


Go to Start | Run | Msconfig, click the Startup tab, and

see what's
running there.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news

group
for everyone to see. I'm sorry, but I don't answer

questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional - Windows Networking
http://mvp.support.microsoft.com

Steve Winograd's Networking FAQ
http://www.bcmaven.com/networking/faq.htm
.

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
lost internet connection through NIC, now dials modem Stephan Internet 4 July 22nd 04 04:30 AM
Internet connection sharing problem Barry Horning Networking 0 July 2nd 04 09:35 AM
home networking - ICS problem Bruce Networking 7 July 1st 04 09:38 PM
need to change the dhcp scope in my Internet Connection Sharing setup Gerry Voras Networking 2 June 24th 04 02:01 AM
Internet connection sharing polar_bear Networking 4 June 16th 04 01:53 AM


All times are GMT +1. The time now is 04:53 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 Win98banter.
The comments are property of their posters.