A Windows 98 & ME forum. Win98banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Win98banter forum » Windows 98 » Plug & Play
Site Map Home Authors List Search Today's Posts Mark Forums Read Web Partners

Detecting whether a device driver is installed



 
 
Thread Tools Display Modes
  #1  
Old September 29th 08, 07:48 PM posted to microsoft.public.win98.pnp
Leslie
External Usenet User
 
Posts: 1
Default Detecting whether a device driver is installed

Hi All,

I have an application that can run on various versions of Windows, i.e. 98,
2000, XP. Unfortunately, there are several device drivers that can be used
by the application DLL. The first iteration used a COTS device driver to run
on WIN98, but a dedicated driver was developed for WIN2K and XP.
Unfortunately, it turns out that some legacy applications can use the earlier
driver while running on XP, in which case the newer driver has not, and
apparently WILL not, be installed. (They want to just plug in the upgraded
hardware without changing any software at all.) I can rewrite our API to use
either driver, but I am looking for a way to detect which driver has been
installed. LoadLibrary will not work, because the new driver is a .SYS file.
Is there a way to detect whether a .SYS file has been installed, other than
doing a directory search?

Thanks in advance,

Leslie
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stop windows 98 from detecting unused device geobentcpht General 1 November 15th 06 07:30 AM
Pc keeps detecting devices already installed Blondeheat2000 General 2 May 29th 06 10:41 PM
Not detecting all disks installed Ricardo Disk Drives 3 February 13th 06 12:59 PM
No ISDN Device installed error Tim Internet 2 November 14th 04 06:59 PM
NTKERN.VXD device loader(s) could not load the device driver (code wayneee General 0 November 6th 04 05:54 AM


All times are GMT +1. The time now is 02:44 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 Win98banter.
The comments are property of their posters.