A Windows 98 & ME forum. Win98banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Win98banter forum » Windows 98 » Shell
Site Map Home Authors List Search Today's Posts Mark Forums Read Web Partners

Problems with installation thru INF files



 
 
Thread Tools Display Modes
  #1  
Old September 13th 06, 07:45 PM posted to microsoft.public.win98.shell
[email protected]
External Usenet User
 
Posts: 1
Default Problems with installation thru INF files

Hi Group,

Ours is a webApplication which uses VC Redistributable
Asssembly's(Dependent on MFC80.dll). For this sake we need to package 2
of the msm files along with our cab file and install them (msm files)
on the Client machine.

This installation we are planning to have it thru inf file. We have
converted the msm files to msi files seperately. We are planning to use
msiexec to install our msi files.

Below is the Inf file which we are currently using.

;INF file for FileFuncs.ocx
;DestDir can be 10 for Windows directory, 11 for Windows\System(32)
directory, or left blank for the Occache directory.

[version]
signature="$CHICAGO$"
AdvancedINF=2.0

[Add.Code]
2.ocx=2.ocx
MFC80.dll=MFC80.dll
MSVCR80.dll=MSVCR80.dll
Microsoft_VC80_DebugOpenMP_x86.msi=Microsoft_VC80_ DebugOpenMP_x86.msi

[2.ocx]
file-win32-x86=thiscab
RegisterServer=yes
clsid={3B28CEBB-694C-42CB-CCB2-137F7B23B918}
DestDir=
FileVersion=8,0,1,0

[MSVCR80.DLL]
file-win32-x86=thiscab
DestDir=11
RegisterServer=No
FileVersion=8,0,50727,42

[MFC80.DLL]
file-win32-x86=thiscab
DestDir=11
RegisterServer=No
FileVersion=8,0,50727,42

[Microsoft_VC80_DebugOpenMP_x86.msi]
file-win32-x86=thiscab
RegisterServer=No

[Setup Hooks]
AddToRegHook=AddToRegHook
hook=hook1

[AddToRegHook]
InfSection=DefaultInstall

[hookl]
run=%EXTRACT_DIR%\Microsoft_VC80_DebugOpenMP_x86.m si


The msi file is not getting installed on the client machine at all. Our
activeX Control is not getting registered because of the msi file not
getting installed.

To Deploy mfc80.dll and its dependent side-by-side assemblies is there
any other way.
Why is this installation failing?

Thanks in Advance

Regards,
suresh

  #2  
Old September 16th 06, 12:47 AM posted to microsoft.public.win98.shell
Gary S. Terhune
External Usenet User
 
Posts: 1,846
Default Problems with installation thru INF files

You might have better luck finding an answer if you ask in a developers
newsgroup. Perhaps there's an MSDN VC forum that would suit. I'm just afraid
that your post here will go unnoticed by the people who might have your
answer.

--
Gary S. Terhune
MS MVP Shell/User

wrote in message
oups.com...
Hi Group,

Ours is a webApplication which uses VC Redistributable
Asssembly's(Dependent on MFC80.dll). For this sake we need to package 2
of the msm files along with our cab file and install them (msm files)
on the Client machine.

This installation we are planning to have it thru inf file. We have
converted the msm files to msi files seperately. We are planning to use
msiexec to install our msi files.

Below is the Inf file which we are currently using.

;INF file for FileFuncs.ocx
;DestDir can be 10 for Windows directory, 11 for Windows\System(32)
directory, or left blank for the Occache directory.

[version]
signature="$CHICAGO$"
AdvancedINF=2.0

[Add.Code]
2.ocx=2.ocx
MFC80.dll=MFC80.dll
MSVCR80.dll=MSVCR80.dll
Microsoft_VC80_DebugOpenMP_x86.msi=Microsoft_VC80_ DebugOpenMP_x86.msi

[2.ocx]
file-win32-x86=thiscab
RegisterServer=yes
clsid={3B28CEBB-694C-42CB-CCB2-137F7B23B918}
DestDir=
FileVersion=8,0,1,0

[MSVCR80.DLL]
file-win32-x86=thiscab
DestDir=11
RegisterServer=No
FileVersion=8,0,50727,42

[MFC80.DLL]
file-win32-x86=thiscab
DestDir=11
RegisterServer=No
FileVersion=8,0,50727,42

[Microsoft_VC80_DebugOpenMP_x86.msi]
file-win32-x86=thiscab
RegisterServer=No

[Setup Hooks]
AddToRegHook=AddToRegHook
hook=hook1

[AddToRegHook]
InfSection=DefaultInstall

[hookl]
run=%EXTRACT_DIR%\Microsoft_VC80_DebugOpenMP_x86.m si


The msi file is not getting installed on the client machine at all. Our
activeX Control is not getting registered because of the msi file not
getting installed.

To Deploy mfc80.dll and its dependent side-by-side assemblies is there
any other way.
Why is this installation failing?

Thanks in Advance

Regards,
suresh



 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which installation files can be removed? computerguy General 2 June 16th 06 01:03 AM
Win98SE Installation problems (Win2k dual boot) computerguy Setup & Installation 6 June 7th 06 02:56 AM
How does windows find the correct device driver? Bazzer Smith Networking 34 May 11th 06 03:03 PM
Other or alternative Windows Updates MEB General 3 March 4th 06 04:20 AM
sluggish performance... Jeff General 3 October 25th 04 08:52 PM


All times are GMT +1. The time now is 10:33 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 Win98banter.
The comments are property of their posters.